Game started crashing, decided to reinstall, now can't redownload

Hey there,


So last night the game started crashing everytime I would try to leave port royal, claiming my system has "run out of memory" (with 10+GB overhead left on the RAM, I don't think that was likely. SSD Game is installed on has lots of room, as well.)


Tried uninstall and reinstall, only for the Bitraider client to basically say "PhysX Software Could not be Found" and then it just quit trying to install the game.


Now no download links for the game seem to want to work at all (just keep giving me time out error when trying to download the installer again).


Thanks,

Chris

Answers

  • Alright, got one of the download portals to work. (One of them. Main ones are still broken.)


    Installer still locks up on PhysX download attempt, though. Starting to get real annoyed at this point.


    Any advice?

  • Heres the bitraider log:


  • The CDN is having issue (it is where you get the installer, dependencies and game files from normally).


    Manually download if game files available here:

    https://drive.google.com/file/d/11lNYlHXilUW5Uq7_9-jRvhCs2gl6GxI4/view

    Regarding out of memory/crashing - turn down texture resolution

    https://forums.burningsea.com/discussion/100460/game-crash-amp-lag

    Support your game. Head over to the BSN-store:
    Pirates of the Burning Sea Store
  • Yeah, at this point I was pretty sure it was down to an issue on the installer end. I've pretty much wiped everything related to PotBS off of the system and started from scratch at this point, with the same result.


    I am running the native output resolution for my monitor, but can try reducing texture resolution. On a GTX 1070FTW2 so VRAM isn't exactly a limiting factor, here. 16GB of DDR3 on an older 3770k, though, but being that DDR3 was the standard when the game was released, I don't see that being the issue. Maybe I'm wrong though.


    Gonna wait for the game files, see if I can't get past this physX thing.


    I tried downloading and installing the required PhysX update straight from nVidia with no success.

  • Got it fired up! Gonna see if the crashing is still a prevalent thing or not.


    The game was playing fine for days, then the crashing started out of nowhere. No major changes.

  • edited June 28

    The out of mem issue it not your machine/hardware


    This is a long-standing problem that comes from the Game Client using up its available memory pool when the game is running in Maximum Graphics Quality mode (highest quality textures, etc). To explain, because the PotBS Client is a 32-bit Application, it is limited to (normally) only being able to access 2 GB of Memory. However, you can patch the current PotBS.exe executable to allow it to access 4 GB of Memory. This will eliminate the texture memory issue and allow you to play the game as long as you like without encountering this issue. You can download the patching tool at the following link: https://ntcore.com/?page_id=371

    Support your game. Head over to the BSN-store:
    Pirates of the Burning Sea Store
Sign In or Register to comment.